Slower than usual response times
Incident Report for Kami
Resolved
Performance issue has been resolved, we've removed a few bottlenecks that prevented us from getting higher performance. This has cleared the backlog. We're monitoring the situation closely and will be rolling out further performance headroom for tomorrow.
Posted Nov 17, 2020 - 17:11 UTC
Update
We're still seeing an average 10 second delay on requests, despite the added capacity. If you're still experiencing issues with requests failing please retry and it should continue to work. Our engineering team are working on removing additional bottlenecks, some of those changes are rolling out in our infrastructure now.
Posted Nov 17, 2020 - 16:36 UTC
Update
We've rolled out changes and we've seen a big increase of performance. Our services are still running. Engineering team is actively monitoring. If you see documents fail to load please refresh. Remember if you notice that your annotations are immediately disappearing, please go to https://web.kamihq.com/web/update_app.html to ensure you're on the latest version without the bug causing it to disappear.
Posted Nov 17, 2020 - 15:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2020 - 15:02 UTC
Investigating
At 3:40am NZT, we began to notice slower than usual response times. Our engineers are rolling out further updates to the backend to increase performance. If you're relying on Kami to save all of your work, Kami's API continues to be operational albeit slow. Please give it time and all of your work, changes, turnins will be eventually successful. Our teams will continue to monitor, and provide updates.
Posted Nov 17, 2020 - 14:59 UTC
This incident affected: API.