Kami/Canvas Integration- Advisory

Incident Report for Kami

Update

We have identified that some Kami users are experiencing degraded performance when accessing Canvas, particularly when assigning or submitting assignments.
Kami’s core functionality remains operational and unaffected. The issues are localized to the integration points with the Canvas platform.
If you experience persistent errors within the Canvas interface, please contact your institutional Canvas support team.

Following a recent security incident reported by Canvas, and in line with their current recommendations, Kami advises all Canvas customers to follow these security best practices.
Ensure Multi-Factor Authentication is enabled on all privileged and administrative accounts, review administrative permissions and user access levels, proactively rotate API tokens or developer keys where applicable, and limit external domain sharing for Google Drive and Microsoft OneDrive to prevent unauthorized data exposure.

For the latest updates on Canvas service health, please visit the official status page: https://status.instructure.com/
Posted May 08, 2026 - 04:55 UTC

Investigating

We have identified that some Kami users are experiencing degraded performance when accessing Canvas, particularly when assigning or submitting assignments.
Kami’s core functionality remains operational and unaffected. The issues are localized to the integration points with the Canvas platform.
If you experience persistent errors within the Canvas interface, please contact your institutional Canvas support team.

Following a recent security incident reported by Canvas, and in line with their current recommendations, Kami advises all Canvas customers to follow these security best practices.
Ensure Multi-Factor Authentication is enabled on all privileged and administrative accounts, review administrative permissions and user access levels, proactively rotate API tokens or developer keys where applicable, and limit external domain sharing for Google Drive and Microsoft OneDrive to prevent unauthorized data exposure.

For the latest updates on Canvas service health, please visit the official status page: https://status.instructure.com/
Posted May 08, 2026 - 04:28 UTC
This incident affects: Kami Canvas Integration.