Speedgrader issue with teachers editing documents
Incident Report for Kami
Resolved
We believe the latest update on production has definitely fixed the issue.
Posted Dec 16, 2020 - 01:20 UTC
Update
We're investigating the possibility that this "This Document has been Turned In" bug also affected students. We will update this message once we confirm more info. But in the meantime, if this is also affecting your students, please have them also update their app using the same link: https://web.kamihq.com/web/update_app.html
Posted Dec 15, 2020 - 19:41 UTC
Monitoring
We identified and fixed a bug that is causing teachers or teacher assistants to see a "This Document has been Turned In" error message when they try to annotate student work from the Canvas Speedgrader. A fix has been rolled out.

If you're affected, to get the fix immediately, please go to https://web.kamihq.com/web/update_app.html to update your app. We don't recommend pushing this out to students since they aren't affected by this bug. Also, Kami will naturally update itself throughout the next 24 hours with this fix, so if you haven't had reports of this issue, it's okay to let the update roll out automatically.

Our teams are working on a way to ensure the root cause of this bug doesn't happen again. We're deeply sorry about this issue.
Posted Dec 15, 2020 - 18:58 UTC
This incident affected: Kami Frontend and Kami Canvas Integration.